ПравилаРегистрацияВход
НАВИГАЦИЯ

Вопросы "чайника"

Модераторы: нет
Список форумов » Вэб-разработкаНа страницу  1, 2, 3 ... 130, 131, 132 ... 233, 234, 235 
АВТОРСООБЩЕНИЕ
JEka
Avatar
Имя: Женя
Сейчас нет на сайте
Репутация: 0
Регистрация: 27.11.2008
Всего сообщений: 405
Откуда: Украина
4 января 2010, 16:48
ФЕЛИКССС,Дык ,Новый Год же! Модераторы сейчас добрые :)
Blackborz
Avatar
Имя: Аслан
Сейчас нет на сайте
Репутация: 1
Регистрация: 13.01.2008
Всего сообщений: 291
Откуда: Чечня
4 января 2010, 20:32
Профи. Я не совсем понял как использовать этот рефер! Куда что писать? И как узнать включен ли он у меня? Пользуюсь денвером! 2м! Настройки не трогал! Джава не подходит. Так как многие пользуются мини оперой!
Profi
Administrator
Avatar
Репутация: 98
Регистрация: 25.04.2006
Всего сообщений: 7072
Откуда: Уфа РБ
4 января 2010, 21:57
Blackborz,
<?php echo '<a href="' $_SERVER['HTTP_REFERER'] . '">Назад</a>'

Но не уверен что на мини-опере будет работать. А вообще пользователь может возпользоваться кнопкой в браузере и эта функция не очень то и нужна.
Blackborz
Avatar
Имя: Аслан
Сейчас нет на сайте
Репутация: 1
Регистрация: 13.01.2008
Всего сообщений: 291
Откуда: Чечня
4 января 2010, 23:19
Че то ниче пе получается! Сначала тупо скопировал скрипт и вставил! Мне денвер выдал страницу с echo 'назад'; нажимаю на эту ссылку (причем ссылкой работает только слово назад. Эчо и запятые написаны черным как простои текст) мне выдает ошибку not found. Пытался записать по правилам. В скриптовые скобки <? скрипт ?> так он вообще страницу не открыл и выдал ошибку parse error. Потом попробовал через <php скрипт php>. Он мне опять выдал Назад';php> и опять not found. Что я не так делаю?
seif
Avatar
Имя: Серега
Сейчас нет на сайте
Репутация: 0
Регистрация: 23.02.2007
Всего сообщений: 155
Откуда: Пермь
5 января 2010, 01:47
Blackborz, пробуй
<?php
echo '<a href="'.getenv('HTTP_REFERER').'">Назад</a>';
?>
Blackborz
Avatar
Имя: Аслан
Сейчас нет на сайте
Репутация: 1
Регистрация: 13.01.2008
Всего сообщений: 291
Откуда: Чечня
5 января 2010, 19:41
Вот спасибо те seif. Заработало!
Феликс
Avatar
Имя: Феликс
Сейчас нет на сайте
Репутация: 0
Регистрация: 1.12.2009
Всего сообщений: 413
Откуда: Ростов-на-Дону
19 января 2010, 12:57
Как на компе протестировать PHP скрипт? Что надо установить?
Profi
Administrator
Avatar
Репутация: 98
Регистрация: 25.04.2006
Всего сообщений: 7072
Откуда: Уфа РБ
19 января 2010, 13:29
ФЕЛИКССС, http://profismart.org/ps12782.php
Mazda
Avatar
Имя: Павел
Сейчас нет на сайте
Репутация: 15
Регистрация: 29.09.2007
Всего сообщений: 3719
Откуда: Нижегородская губерния.
20 января 2010, 20:55
Сразу говорю, я ничего не понимаю в сайтах :) .
На одном сайте ucoz почти всегда стала появляться "код ошибки: 504" или очень долго грузится страница.
Это что то с сайтом случилось или с сервером? Если с сайтом то что сделать что бы сайт опять нормально заработал?
(эта ошибка не у меня одного)
Profi
Administrator
Avatar
Репутация: 98
Регистрация: 25.04.2006
Всего сообщений: 7072
Откуда: Уфа РБ
20 января 2010, 23:35
Mazda, если косяк не в твоих скриптах, то вероятно сервер перегружен и скрипты не успевают выполняться. Можно просить тех.поддержку увеличить лимит на время выполнения скриптов, только если это из за перегрузки сервера, то это только усугубит ситуацию.
Список форумов » Вэб-разработкаНа страницу Пред. 1, 2, 3 ... 130, 131, 132 ... 233, 234, 235 След.
 
стр.  
Страница 131 из 235
Часовой пояс: GMT + 4
Мобильный портал, Profi © 2005-2016
Время генерации страницы: 0.021 сек
Общая загрузка процессора: 4%
SQL-запросов: 4
Rambler's Top100