ПравилаРегистрацияВход
НАВИГАЦИЯ

Учим PHP

Модераторы: нет
Список форумов » Вэб-разработкаНа страницу  1, 2, 3 ... 7, 8, 9 ... 86, 87, 88 
АВТОРСООБЩЕНИЕ
Profi
Administrator
Avatar
Репутация: 98
Регистрация: 25.04.2006
Всего сообщений: 7003
Откуда: Уфа РБ
2 июня 2008, 23:27
Цитата:
seif 2.06.2008
белая страница возникает иногда тоже иза ошибок
-----
вот тут и поможет показ ошибок, т.к. судя по всему показ ошибок отключен
Chasovoi
Avatar
Имя: Игорь
Сейчас нет на сайте
Репутация: 0
Регистрация: 13.10.2007
Всего сообщений: 619
14 июня 2008, 11:22
Profi, ВНИМАНИЕ! -
arg_separator.output "&" Вы можете продолжить установку, однако настоятельно рекомендуется установить этот параметр на "&", иначе будут неправильно обрабатываться гиперссылки в XHTML.
А вот кусок этого кода где надо установить этот параметр. if (ini_get('arg_separator.output') == '&') . Блин, где я только не пытался его устанавливать, не верно все равно. Где же его нужно установить? Параметр этот.
Profi
Administrator
Avatar
Репутация: 98
Регистрация: 25.04.2006
Всего сообщений: 7003
Откуда: Уфа РБ
14 июня 2008, 11:59
Так это условие. Хоть куда устанавливай, всё равно будет неправильно :)
Условие есть, а чего делать при этом условии непонятно.
И вообще непонятно чем оператор htmlspecialchars плох? И почему нельзя сразу вид ссылки правильно прописать? В общем ничего не понятно.
Chasovoi
Avatar
Имя: Игорь
Сейчас нет на сайте
Репутация: 0
Регистрация: 13.10.2007
Всего сообщений: 619
14 июня 2008, 12:09
Profi, ну и что? Продолжить установку? Оставить так? Там вообще нужно было изменить register_globals OFF на ON, затем magic_quotes_gpc ON изменить на OFF, и осталось только изменить arg_separator.output, что не удается.
Chasovoi
Avatar
Имя: Игорь
Сейчас нет на сайте
Репутация: 0
Регистрация: 13.10.2007
Всего сообщений: 619
14 июня 2008, 12:12
Вот вообще все что там написано. if (ini_get('arg_separator.output') == '&')
{
echo '<span class="green">OK</span> - arg_separator.output "&amp;amp;"<br />';
} else
{
$err = 2;
echo '<span class="red">ВНИМАНИЕ!</span> - arg_separator.output "' . htmlentities(ini_get('arg_separator.output')) . '"<br />';
echo '<span class="gray">Вы можете продолжить установку, однако настоятельно рекомендуется установить этот параметр на "&amp;amp;",<br /> иначе будут неправильно обрабатываться гиперссылки в XHTML.</span><br />';
Profi
Administrator
Avatar
Репутация: 98
Регистрация: 25.04.2006
Всего сообщений: 7003
Откуда: Уфа РБ
14 июня 2008, 12:51
В .htaccess добавь строчку
php_value arg_separator.output "&amp;"
Chasovoi
Avatar
Имя: Игорь
Сейчас нет на сайте
Репутация: 0
Регистрация: 13.10.2007
Всего сообщений: 619
14 июня 2008, 13:00
Profi, у меня хост не позволяет в htaccess вообще строки начинающиеся на php_, там я наоборот все эти строки закоментировал. Вот служба поддержки хоста пишет. : Попробуйте в файле
incfiles/func.php прописать
строчку
ini_set(arg_separator.output,
"&amp;")
ошибка не исчезнет но скрипт будет работать корректно. Домой приду попробую.
Profi
Administrator
Avatar
Репутация: 98
Регистрация: 25.04.2006
Всего сообщений: 7003
Откуда: Уфа РБ
14 июня 2008, 13:03
Ну правильно пишет. Это просто обман скрипта.
Chasovoi
Avatar
Имя: Игорь
Сейчас нет на сайте
Репутация: 0
Регистрация: 13.10.2007
Всего сообщений: 619
14 июня 2008, 14:19
Profi, обман скрипта? :) прикольно. Так в том файле в любом месте можно ту строчку написать? Так?
Profi
Administrator
Avatar
Репутация: 98
Регистрация: 25.04.2006
Всего сообщений: 7003
Откуда: Уфа РБ
14 июня 2008, 15:26
Нужно прописать выше проверки
Список форумов » Вэб-разработкаНа страницу Пред. 1, 2, 3 ... 7, 8, 9 ... 86, 87, 88 След.
 
стр.  
Страница 8 из 88
Часовой пояс: GMT + 4
Мобильный портал, Profi © 2005-2016
Время генерации страницы: 0.019 сек
Общая загрузка процессора: 4%
SQL-запросов: 4
Rambler's Top100